Datto Siris Virtual Appliance

I am wondering if anyone has experience with a Datto Virtual Appliance in the ProfitBricks Cloud? I hear it is possible, but am running into an issue.

I loaded the OVA image file on my local esx server and transferred the VMDK to the Bricks cloud. The issue I am having is the virtual NIC's don't seem to be able to see the internet or get an address from DHCP. I am guessing it is some sort of nic incompatibility with the virtual host. Does anyone have experience with this?

  • **bold**
  • _italics_
  • `code`
  • ```code block```
  • # Heading 1
  • ## Heading 2
  • > Quote

Hello - I haven't worked with that virtual appliance yet. I will have to check it out soon. Reading through the issue, I'm curious if you tried using a static / reserved IP address with the appliance or just DHCP. If I recall correctly the DHCP addresses use a /32 netmask and perhaps that is causing an issue with the appliance. There is a brief mention of this at: Scroll down to "Manually Assign IP Addresses".

Hi again - I tried out the virtual appliance install and noticed the same error you reported regarding the network connection. It appears during the initial boot of the virtual appliance. I was able to work around it and get the error to disappear by setting up the virtual appliance behind an IPFire firewall that was running its own DHCP server. (This also required unchecking the "DHCP - Gateway IP will be assigned" option on the server's network tab in the DCD.) Based on the DHCP status listed on the firewall, an IP was assigned to "backupDevice", which matches the hostname the Datto documentation lists for an unregistered device. Datto KB Setup

I don't have an "Authorization Code" so I can't proceed any further with the installation to confirm that the issue is fully resolved.